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What is PHPoC Debugger?

PHPoC Debugger

PHPoC Debugger is a software used for development and management of PHPoC Products. It is
required to install this program before using PHPoC.

Go to Download PHPoC Debugger

Features of PHPoC Debugger

Upload files from local PC to PHPoC
Save files which are in PHPoC to local PC
Edit files stored in PHPoC
Debug PHPoC scripts
Monitor PHPoC's resources
Configure PHPoC's parameters
Upgrade Firmware of PHPoC
Support Platform: MS Windows

http://www.phpoc.com/download.php#download_tools
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User Interface

User Interface
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1. Menu bar

Menu Sub menu Description

File

New Create a new php file
Upload a poc file Upload a poc format file
Save selected file(s) Save selected files in file list to local PC
Save a poc file Save all files in file list to local PC (.poc)

Edit

Undo Undo the latest job
Redo Redo the latest job undone

Cut
Cut the selected text and copy it to the
clipboard

Copy Copy the selected text to the clipboard
Paste Paste text from the clipboard
Select all Select all texts
Find Find the specified text
Find Next Find the next text by down direction
Find Previous Find the next text by up direction
Change Replace the specified text with given text
Preferences Program preference

Function

System information
Product/Firmware, Flash files, IP Address,
Wireless LAN, ARP/NDC Table, PDB Net

Smart expansion board
information

Smart expansion board information and
Check for updates menu

View error log PHP, Firmware, SYS/Stdout tx
Reboot a product Reboot a product
Firmware Debug mode Enable/disable Firmware debugging mode
PHP Debug mode Enable/disable PHP debugging mode
Font Change font
Language Change language

Software information
Information about PHPoC Debugger and
Check for update button

help
Debugger manual(online) Go to PHPoC debugger manual page
PHPoC manual(online) Go to manual page of phpoc.com
Forum Go to PHPoC forum

Preferences

Menu Sub menu Description

View

View margin Show/hide margin
View line number Show/hide line number on margin
View current line Enable/disable current line emphasis

Line ratio
Set line space:
100, 120, 150, 200, 300

Tab size Set tab size: 1, 2, 4, 8, 16

Action of file add
Internal editor Use the internal editor
External editor Use an external editor
Ask Show select option every time

Backup path Path of backup files and log files

Initialization
Enter initialization
mode

Set product to initialization mode

Updating the Debugger Automatically check
Check for the updates every time
debugger runs

mDNS service subtype mDNS service subtype

2. COM PORT

Part for choosing a virtual USB COM port
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3. Buttons

Button Description

Connect to PHPoC product

Disconnect from PHPoC product

Configure environmental values of PHPoC product

Upload files on [File list] to PHPoC product

Stop running PHPoC codes

 
Run/pause PHPoC codes

Run line by line

Run procedure by procedure

4. File list

List of files saved PHPoC product or to be uploaded.

Icon Description
Synchronized files

Files on PHPoC product before synchronization

Files on local PC before synchronization
Synchronized files on local PC for external editors

The following menus will be popped up when right clicking on file list area.

Menu Description
Run Run the script selected immediately
Change the filename Modify a file name
Delete Delete files on the list
File information Show the information of a selected file
New Create a new php file
Add Add files from local PC
Change firmware Upload the firmware selected to PHPoC

5. Editor

Showing and editing contents of selected file on the file list. The following menus will be popped up
when right clicking on editor area.

Menu Description Shortcut
Toggle Breakpoint Set / Unset break point on current line F9
Remove All Breakpoints Unset all break points on current file Shift+F9
Step Into Run line by line F11
Step Over Run procedure by procedure F10
Run to the current line Run and pause before executing the current line -
Cut Cut the selected codes and copy it to the clipboard Ctrl+X
Copy Copy the selected codes to the clipboard Ctrl+C
Paste Paste codes from the clipboard Ctrl+V
Select all Select all codes Ctrl+A
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6. Flash memory size

This shows currently available or in-use space on flash memory of PHPoC product.

7. Output / FW Log

This window is for displaying standard output and F/W log messages. The following menus will be
popped up when right clicking on the windows.

Menu Description
Delete all logs Clear screen buffer
Copy Copy the selected log to the clipboard
Auto scroll Set / Unset auto scroll
Delete logs at run time Clear screen buffer every time the script runs

Save logs
Save the log in the Output window and FW Log window as a file in
the Backup path.

8. Watch / Resource

This window is for checking run time variable information and system resources. The following
menus will be popped up when right clicking on the watch window.

Menu Description
Add Add a variable
Modify Modify a name of the selected variable
Delete Delete the selected variables
Delete all Delete all variables
Detail Create a new window for detailed information
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Installation

1. Downloading PHPoC Debugger

Download PHPoC Debugger on the link below.

Go to the Download Page

2. Running the Installation File

Unzip and run the installation file.

3. Press the "Next" button.

http://www.phpoc.com/download.php#download_tools
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4. Select the "I accept the terms in the license agreement" option.

5. Press the "Next" button.
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6. Press the "Install" button.

7. Press the "Next" button.



PHPoC Debugger Manual > Installation

2021-01-15 Sollae Systems page 9 of 45

8. Press the "Finish" button.

9. Press the "Finish" button.
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Preparation

1. Install the PHPoC Debugger

Download and install PHPoC Debugger referring to the Installation chapter.

2. Connect the PHPoC to PC

Connect the device port of PHPoC to your PC via a USB cable.

3. Run the PHPoC Debugger

Select connected COM PORT and press connect ( ) button. If USB is successfully connected,

connect button will be inactivated and disconnect button ( ) will be activated

※ If the USB connection can be disconnected due to unexpected external noise such as static
electricity. In this case, you will show the message "It is disconnected from the product. Do you want
to connect to it again?" and it will try to connect it again when pressing the "YES" button.

http://www.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=install
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Uploading Files to PHPoC

Php files in local PC can be uploaded to PHPoC.

How to Add Files to File list

Drag & Drop

Select and drag files on Window explorer to file list box and drop them.

Add menu

If you click [Add] after right-clicking in the file list box, a window for selecting files will be created.
Selected files on the windows will be added to the file list

Upload files

Files in the file list will be uploaded to P4S-341 by clicking upload ( ) button. If the uploading
is completed, both files on the file list and in P4S-341 are synchronized and the icons are changed

to ( ).
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Upload an Integrated File(.poc)

You can upload an integrated file (.poc) with procedures below.

Click [File] > [Upload a poc file] menu.1.

Click [Open] after selecting a poc file.2.
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Click [Upload flash files] button.3.

Choose yes or no about deleting existing flash files.4.

※ Caution: If you choose [Yes], all flash files stored in PHPoC are deleted.

Click [OK] to finish upload a poc file5.
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Downloading Files to PC

Downloading Files to PC

Select files in file list1.

Click [File] > [Save selected file(s)]menu on menu bar2.

Choose a path and click [OK] button.3.



PHPoC Debugger Manual > Major Functions > Downloading Files to PC

2021-01-15 Sollae Systems page 15 of 45

Save as a Integrated file (.poc)

When you want to save all files on the file list as a single file, use [Save a poc file] menu.

".poc" is filename extension. Input filename and click [Save] button.
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Practice

Create init.php

Notice : Operation of PHPoC

PHPoC searches init.php file after booting. If PHPoC fails to find a file named
init.php, it does not run any code. Therefore, you need to make or upload
init.php to the file system of PHPoC.
You can write main scrip to init.php but PHPoC runs the file only once. If you
wants to run their code more than once, write the main script in another file
and load the file by using "php" command of system function. A file loaded by
system function is repeatedly run even execution is ended.

Click file list with the right button of your mouse and select [New] menu.

Input "init" into the file name box.
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Select init.php file in the file list.

Input the following command lines into the editor.

Click upload button( ).

After PHPoC finishes uploading files, icon will be changed. (  → )

Excecute Scripts

PHPoC automatically runs a script when it boots up or uploads file system. You can find the result in
the Output window of PHPoC Debugger.

※ If [PHP debug mode] option of PHPoC Debugger is enabled, PHPoC does not execute a script

automatically. You can manually run the script by clicking the Run button. ( )
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Using PSP Examples

PHPoC Support Package (PSP) contains libraries and example codes. This package is provided to
help you use PHPoC conveniently. Before starting test run, download it in your local PC.

Go to the Download Page

Choosing an Example

PSP contains many examples using various sensors. Choose an example you are interested in and
upload the files to PHPoC. There are three categories.

basic task examples

These examples require uploading both "init.php" and "task0.php".

web task examples

These examples require uploading "index.php" and a set of image files if there are any.

both basic and web task examples

These examples require uploading "init.php", "task0.php" and "index.php" including a set of
image files if there are any.

http://www.phpoc.com/download.php
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Using Examples

Find and upload 00.hello example in the p4s/01.php_task folder.

You can find a result message right after uploading the files.
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Using an External Editor

In case that you do not want to use PHPoC Debugger's internal editor but external editor, just set
[External editor] option of [action of file add] item on preferences window.

When you upload php files with this option, the lock icons below will be shown on the synchronized
files. Files with this icon cannot be modified by internal editor of PHPoC Debugger but external
editors.
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Debugging PHP

PHPoC provides run-time debugging function. Buttons for debugging are enabled when you check
the PHP debug mode option in PHPoC Debugger. In this mode, you can set break points or check
values of variables at every code line.

Once the PHP Debug Mode is activated, debugging buttons are available. You can debug your script
with this buttons through the [Watch] window.
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Simple Tutorial

Activate the PHP Debug Mode.1.

Write the following code on init.php and upload it.2.

<?php
$var_int = 1;
$var_str = "abc";
$var_arr = array(1, 2);
?>

Clicking the right button on your mouse and select [Add] menu.3.

Enter "var_int" in the textbox as a name of variable and click [Add] button.4.

Add the following variables in the same way.5.

var_str
var_arr
var_arr[0]
var_arr[1]

Check values of variables in the [Watch] window while running the script line-by-line using6.
Step-In(F11) button.

※ Caution: In the case of a variable which is an array, key has to be specified with name of array to
watch the value
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Online Upgrade

You can check the updates for PHPoC debugger if the PC is connected to the Internet. This function
checks whether the currently running PHPoC debugger is the latest version. If it is not the latest
version, you can upgrade the debugger online.

Check for updates manually

Select the [Function] > [Software information] on the menu bar. You can check updates by pressing
the [Check for update] button.

If you are not using the latest version, you can upgrade to the latest version.

Check for updates automatically

Select the [Edit] > [Preferences] on the menu bar then [Preferences] window will pop up. Check the
[Automatically check] in the [Updating the Debugger] section and press the [Apply] button.



PHPoC Debugger Manual > Other Functions > Online Upgrade

2021-01-15 Sollae Systems page 24 of 45

After that, PHPoC debugger checks updates online every time you run it. The following notification
window will pop up if there is a new update.
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Connection via Network

The connection via network function is to connect the PHPoC debugger and the product via the
network instead of the USB cable. Even you connect your product via network, you can use almost
all of the functions such as product settings, script editing and debugging. For using the connection
via network function, the product is required to be setting related to the function.

※ How to set up the connection via network for PHPoC products

Select COM Port as [Network] and click Connect( ) button then you can see the Network
Connection window.

Search Connection

If the PHPoC product is on a local network, you can use the Search connection function. This
function searches for products on the local network and connects to the products found. If you click
the [Search] button in the Network connection window, all the PHPoC products on the local network
will be searched.

http://www.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=manage_config_remote
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Response Type
You can select the response type when the response packet is sent by the PHPoC product that
received the search packet.  If Unicast is selected, the response packet is sent only to the PC
that sent the search packet.  Selecting Multicast sends a response packet to all hosts in the
Multicast group.

Response Time
Depending on network environment, you can increase response latency by adjusting this value
if the response packet is delayed and the discovery fails.  You can choose from 1, 2, 4, or 8
seconds.

Select the product and click [Connect] button to try remote connection immediately.

Manual Connection

This function connects directly to your product after filling the items which are required to
connection via network. Press the [Connect] button after inputting the IP address, URI path, port and
selecting protocol on the Manual connection tab.

※ It is recommended to enable the Remote debugger option in the product settings for using this
function.
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Address
This is the IP address of the product.

URI Path
This is the URI Path of the product. This value is fixed to "pdb" if the Remote debugger option
is activated to the product.

Port
This is the port for connection via network. This value is fixed to "57457" if the Remote
debugger option is activated to the product.

Protocol
This is the protocol for remote connection. Select HTTP if the product's remote connection
protocol is pdb-ws, or HTTPS if pdb-wss.

Restrictions

In contrast with USB connection, there are some restrictions with the connection via network.

Division
Network
(HTTP)

Network
(HTTPS)

USB

Configuring Password Not available
Available
(except for the admin password)

Available

Uploading F/W Not available Not available Available
Managing Certificates Not available Available Available
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Settings

All parameters including an IP address can be configured through PHPoC Debugger.

Setting Steps

Connect PHPoC product to PC via USB.1.
Run PHPoC Debugger.2.

Click the connect button( ) after choosing the right COM port.3.

After then, click configuration ( ) button.4.
Configure parameters.5.
Click the [Save] button to save the configuration.6.

※ Note: You can also set PHPoC products via Connection via network.

Setting Parameters

Tab Category Parameter

IP Address

IPv4

IP address type - Obtain an IP automatically
IP address type - Use static IP address
IP Address
Subnet mask
Gateway IP address
IP address type - Obtain DNS server address automatically
DNS server IP address

IPv6

IPv6 - Enable / Disable IPv6
IP address type - Obtain an IP automatically
IP address type - Use static IP address
EUI - MAC Address / Random
IPv6 address and Prefix
Gateway IPv6 address
Obtain DNS server address automatically
DNS server address

Wireless LAN
Basic Settings

WLAN - Enable / Disable WLAN
WLAN Topology - Infrastructure / Soft AP
Search AP / Search channel
Channel
SSID
Internal Antenna / External Antenna
Advanced Settings

Security
Shared Key
802.1X: EAP-TTLS / PEAP

http://www.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=etc_remote
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Advanced

Time Set RTC time
Password Password (ID: admin, pdbuser, setup)

Certification

Type - Host / Client / Root CA
Write certificate
Write signed certificate from certification authorities
Read the certificate form a product
Delete the certificate form a product

Network

Local LAN name server
Service discovery
Network debugger
Secure network debugger
Remote debugger
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Setting Passwords

If you set a password for the product, you must enter the password when connecting the product
via USB or network. There are three default accounts for the PHPoC product, and you can set a
password for each account.

ID Name Authority
Password

management

admin administrator
developer authority + setting the connection
via network

all accounts

pdbuser developer
end-user authority + accessing the file
system, debugging, managing the
certification

pdbuser, end-user

setup end-user setting and monitoring products -

※ Caution: PHPoC does not support restoration when you forget your password. In that case, you
can delete the password by using Device Initialization but all settings and files are also deleted.

How to set up

Creating a password

Connect your PHPoC product and click the Setup( ) button. Click the [Advanced] button on the
Product settings window and select the [Password] tab. Then you can set a password to each
account.

http://www.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=manage_freset
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Passwords can be from 8 to 32 letters, numbers, special characters or a combination of these.

Changing a password

To change the set password, select the account, check the [Change] option, and enter the password
to be changed in [Password] and [Retype Password].

Deleting a password

To delete the set password, select the account and click the [Delete] button.

※ Caution: If you connect to the product via USB, you need to set the password for the
administrator account (admin) first in order to set the password for the developer (pdbuser) or end-
user (setup) account.
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Managing Certificates

The certificate is required to use the secure communication function of PHPoC. There are three types
of certificates: Host, Client, and Root CA.

Connect a PHPoC to the PHPoC debugger and select [Certification] tab on [Settings] > [Advanced]
menu. Choose a type of certificate and click a menu to run.

Write certificate

This menu creates a certificate and stores it to PHPoC.



PHPoC Debugger Manual > Managing PHPoC > Settings > Managing Certificates

2021-01-15 Sollae Systems page 33 of 45

Write signed certificate from certification authorites

This menu stores a certificate issued by the other certification authority to PHPoC. Click the [Open]
button to select the certificate and save it.

If there is a password in the certificate, a window for entering the password will pop up.

If there is a separate key file with the certificate, the window to load the key file will pop up.
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Read the certificate from a product

This menu shows the certificate currently stored in PHPoC.

Delete the certificate from a product

This menu is for delete the certificate stored in PHPoC.



PHPoC Debugger Manual > Managing PHPoC > Settings > Setting Connection via Network

2021-01-15 Sollae Systems page 35 of 45

Setting Remote Connection

Connect your PHPoC product and click the Setup( ) button. Click the [Advanced] button on the
Product settings window and select the [Network] tab; then you can set the four options for remote
connection.

Local LAN name server
This enables mDNS function. You need to set this option to use searching function in local
network of PHPoC debugger.

Service discovery
This enables searching function. You need to set this option to use searching function in local
network of PHPoC debugger.

Network debugger
This enables remote connection. You need to set this option both to use searching function
and network connection by PHPoC debugger. The protocol for connection via network is set
to pdb-ws if you set this option without setting the [Secure remote debugger] option.

Secure remote debugger
This enables encrypted remote connection. You need to set this option both to use searching
function and encrypted network connection by PHPoC debugger. The protocol for connection
via network is set to pdb-wss if you set this option.
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※ Note: You must set a password for at least one account in order to make a network
connection using the secure network debugger(pdb-wss).

Remote debugger
Check this option if you want to use a manual connection. When this option is activated, Path
and Port are fixed as follows.

Division Port Path
Remote debugger is activated 57457 pdb
Remote debugger is inactivated product's default product's default

※ You can find the product's default values of Port and Path from the [PDB Net] tab of
[function] > [System information] in PHPoC debugger's menu bar.

http://www.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=manage_config_password
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Upgrading Firmware

New firmware can be released when adding functions or fixing bugs. If you are using old firmware,
you can upgrade it to new one. PHPoC Debugger provides both online and manual upgrade.

Online Upgrade
Manual Upgrade

http://www.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=manage_fw_auto
http://www.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=manage_fw_manual
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Online Upgrade

You can upgrade firmware online if your PC is connected to the Internet.

Procedure

Connect PHPoC product to your PC via a USB cable.1.

Run PHPoC Debugger and click connect ( ) button after choosing the right COM port.2.

Click the [Function] > [System information] menu.3.

Select the [Product/Firmware] tab and click the [Check for update] button on the System4.
information window.
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Click [OK] after uploading F/W is finished.5.

Upgrading F/W of Smart Expansion Boards

You can upgrade firmware of smart expansion boards if they are connected to your PHPoC board.

Connect PHPoC board with smart expansion boards to your PC via a USB cable.1.

Run PHPoC Debugger and click connect ( ) button after choosing the right COM port.2.

Click the [Function] > [Smart expansion board information] menu.3.
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On the [Smart Expansion Board Information] window, right-click the product and select the4.
[Check for Updates].

Click [OK] after uploading F/W is finished.5.
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Manual Upgrade

Checking the Version of F/W

Check the current version of F/W before upgrading it.

Checking the current version of F/W

You can check it on the [Product/Firmware] tab from the [Function] > [System information]
menu in the PHPoC Debugger.

For a smart expansion board, you can check it in [Function] > [Smart expansion board
information] menu.
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Checking the latest version of F/W

You can check the latest version of F/W on download page on phpoc.com.

Procedure

Download the latest F/W file.1.
Connect PHPoC product to your PC via a USB cable.2.

Run PHPoC Debugger and click connect ( ) button after choosing the right COM port.3.

Click the [File] > [Upload a poc file] menu.4.

Select the F/W file and click the [Open] button.5.

http://www.phpoc.com/download.php#firmware
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Click the [Upload firmware]/[Upload Slave] button.6.

For a smart extension board, click the product to upload and press the [Select] button.

Click [OK] after uploading F/W is finished.7.
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Device Initialization

Device Initialization makes all settings of your PHPoC product including a password initialize to
default. Futhermore, all files stored in flash memory are deleted as well as certificate. Because of this,
you have to backup your files before doing the device initialization.

Device Initialization Procedure

Step Action Product State STS LED
1 Run PHPoC Debugger - -

2
Set PHPoC to initialization mode(Use
[Edit]>[Preferences] menu on PHPoC
Debugger)

Enter Initialization
mode after reboot

Blink
rapidly

3
Keep pressing the function button over 10
seconds

Preparing initialization
Blink very
rapidly

4 Check STS LED after 10 seconds Initialization ready Off

5

Release the function button right after the
STS is OFF.(※ If you don't release the button
within 2 seconds, the state go back to the
step 3)

Progressing
initialization

On

6 Rebooting automatically Initial state Off
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